忍者ブログ

Azukish

消えゆく世界と流れる未来に最後の灯を since 2006/4/3

2015/10/22

LinuxでIntelのオンボを利用してブルーレイを見るのは不可能?

LinuxでIntelのオンボを利用してブルーレイを見るのはどうも無理っぽい。
色々とやってみたけれど、自分はダメだった・・・。
省電力・静音性重視な自分のデスクPC
入れたのはIntelの蓮な低消費電力用CPU。
バルクでのみ売ってたタイプの、普通のT付きより若干動作周波数が高いやつ。
Intel® Core™ i3-4330T Processor (4M Cache, 3.00 GHz) 仕様

以下色々と苦心の跡を綴りまする・・・

ブルーレイを見るため(見たいだけ、複製はしない)にはlibaacs.soが必要と偉い人が言ってたので、VideoLAN - libaacsからダウンロードして./configure→make&make install
同様にしてlibbluray.soもVideoLAN - libblurayからダウンロードしてインスコ
その過程でlibva-intel-driverとかlibvdpau-va-glとか必要かも。
で、vlcを起動すると、vdpau_avcodec generic error: decoder profile not supported: 2とかいうエラーが発生。
Javaのパスを通して、libaacs、libblurayのパスも通して(どうもライブラリが/lib64/に入ってて、libbluray-j2se-バージョン.jarが/usr/share/java/に入ってないとダメっぽい)起動しても同様のエラー。

で、色々と調べてみた結果、次の記事を発見。
VDPAU / VAAPI * AMD A10 kaveri / Cinnamonが立ち上がらない
CPUは違うものの、この人のCPUはハードウェアアクセラレーションとかいうやつに対応してないらしい。

自分もならってやってみる。
$ vdpauinfo
・・・省略・・・
Decoder capabilities:
name                        level macbs width height
----------------------------------------------------
MPEG1                          --- not supported ---
MPEG2_SIMPLE                   --- not supported ---
MPEG2_MAIN                     --- not supported ---
H264_BASELINE                  51 16384  2048  2048
H264_MAIN                      51 16384  2048  2048
H264_HIGH                      51 16384  2048  2048
VC1_SIMPLE                     --- not supported ---
VC1_MAIN                       --- not supported ---
VC1_ADVANCED                   --- not supported ---
MPEG4_PART2_SP                 --- not supported ---
MPEG4_PART2_ASP                --- not supported ---
DIVX4_QMOBILE                  --- not supported ---
DIVX4_MOBILE                   --- not supported ---
DIVX4_HOME_THEATER             --- not supported ---
DIVX4_HD_1080P                 --- not supported ---
DIVX5_QMOBILE                  --- not supported ---
DIVX5_MOBILE                   --- not supported ---
DIVX5_HOME_THEATER             --- not supported ---
DIVX5_HD_1080P                 --- not supported ---
H264_CONSTRAINED_BASELINE      --- not supported ---
H264_EXTENDED                  --- not supported ---
H264_PROGRESSIVE_HIGH          --- not supported ---
H264_CONSTRAINED_HIGH          --- not supported ---
H264_HIGH_444_PREDICTIVE       --- not supported ---
HEVC_MAIN                      --- not supported ---
HEVC_MAIN_10                   --- not supported ---
HEVC_MAIN_STILL                --- not supported ---
HEVC_MAIN_12                   --- not supported ---
HEVC_MAIN_444                  --- not supported ---
・・・省略・・・


どうも対応してないっぽい
次に、何かドライバ的なものがないか調べてみる。
VDPAU - ArchWikiに載ってた。
As of version 0.3, the VA GL driver doesn't support any other hardware decoder than H.264.
バージョン0.3の段階では、どのハードウェアでもVA GLドライバはH.264以外のデコードは無理だってさ。
どうもハードウェアアクセラレーションは使えないっぽい。
何かいい方法は無いものか・・・

追記 なお、CPUがハードウェアアクセラレーションに対応しているならば、たぶんlibaacs、libbluray、libbluray-bdjを入れればどうにかなるんじゃないかな?

拍手

コメント













カウンター

カレンダー

11 2017/12 01
S M T W T F S
1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30
31

アーカイブ

AD

Azkishはamazon.co.jpを宣伝しリンクすることによって サイトが紹介料を獲得できる手段を提供することを目的に設定されたアフィリエイト宣伝プログラムである、 Amazonアソシエイト・プログラムの参加者です。